iH8Sn0w Releases iFaith v1.2.2

iH8Sn0w has released iFaith 1.2.2, an update to his tool that dumps the SHSH Blobs of your current firmware, even if Apple is no longer signing that version.

- Added iPod Touch 2G Dumping capability (MC-Model users recommened)
- IPSW Creation for iPod Touch 2G is still a work in progress.
- Fixed exe compression issues (resulting in many DFU loops on IPSW creation).
- Fixed any Windows XP issues.
- Detects if the user inputs a decimal ECID when checking for available blobs.

Devices Supported:
iPhone 3G[S]
iPhone 4
iPod Touch 3G
iPod Touch 4
iPad 1G
Apple TV 2

Developer Notes:
When I released iFaith v1.0, you probably noticed that the dumping was way faster than v1.1 and v1.2. In 1.1, I specifically made it dump slower since there seemed to be a swarm of users that got into a DFU Loop. I initially thought that this was because USB was not able to keep up with the dump.

So I released 1.1 about a month later which integrated SHA-1 verification and slower dumping to ensure that what was being dumped over USB was what was on the device and what iFaith was receiving. I thought this would resolve the issue but it doesn't seem to have. So, I later came to notice that the exe compression/encryption on iFaith was causing some read/write issues with IO on the pc side.

When I sent mostwanted a beta build via Twitter, he did indeed say that it was successful. The build I had sent him was just a rebuild of v1.1 without any compression or encryption. It is available here

I still see people complaining though that their getting DFU loops. The reason you'd be getting a DFU loop is that LLB and/or iBoot's SHSH Blobs were not properly dumped or written. Frankly, if you got a corrupt blob. Its virtually impossible to fix. Not until someone were to get a hold of Apple's SHSH signing keys. Which would make this app totally useless.

As of now, I'm sorry if your device is in a loop and you don't have any SHSH saved via TinyUmbrella or Cydia. Lets hope that v1.2.2 is the golden version. If you dumped blobs using v1.0 or v1.1 and got a DFU loop when building the ipsw with v1.2.2, then your blobs are useless pretty much. There isn't any other way I can put it.

At least I'm not hiding in the shadows pretending I'm not hearing this.

Yours truly,

Subscribe for Latest News